OS X keyboard locking issue

I’ve been dealing with this problem with my Powerbook 12″ lately which has been the source of neverending frustration: while using my laptop occassionally the keyboard will stop working. For a while I thought that the only way to cure my ill computer was to reboot it, and with Google providing no help, I was just about to stick my silver friend in the microwave to teach it a lesson.

Over the past month or so, I’ve discovered quite a few features of this peculiar bug. The first thing I recognized was that not all of the keys were frozen: most of the option and F-keys still provided their full functionality, such as App switching (Commant-Tab), brightness control (F1-F2), etc. Still nothing would repair this ailment, and I’d eventually end up rebooting.

But last night I made a major breakthrough: while locked, I tried to Force-quit (Command-Option-ESC), and suddenly my keyboard was returned to normal. I quickly tried seeing if it was related to any of my running applications: not iTerm, not BBEdit, none of them seemed to affect it. But, while switching applications once I tried to not use Command-Tab, and low and behold, the problem went away entirely.

Whenever I use Command-tab to switch applications now, there’s a good chance that my keyboard will lock. Has anyone ever encountered this problem before? Either I’m a really peculiar user or it’s something specific about the applications I use (I just reinstalled last week).

Very strange.

Update: I realized that when the machine gets into this state, any Cmd-Tab operation will render the keyboard unusable (until you run force-quit), but a reboot returns things to the normal operation. Relaunching the Finder has no effect, so it’s as if the kernel gets into a state where application switching causes the keyboard to hang.

34 thoughts on “OS X keyboard locking issue

  1. Yes. Me too. Happens about once every 2 weeks or so. I cannot divine the rhyme/reason. Typically, BBEdit is open. So are about 12-20 other apps, usually. But, it also happens without BBEdit. I cannot find a pattern, but selecting “Quit” via mouse 20 times in a row is a real pain in the arse.

  2. Weird. Perhaps you could replace Apple’s built-in app switcher with something like LiteSwitch? It isn’t free but perhaps you could give it a go for a few days to determine what’s causing the bugginess.

  3. Ahhh, yes, one once asked me how it was that I came to understand the Apple in such ways. I really can’t say whether or not it was my great friend the swiss shepherd, William Tell, who thought so much of Apple that he chose to shoot it with arrows. Or was it that Isaac Newton, who studiously observed apples falling from tree stem to the ground? What I can say is this, either shoot your Apple with an arrow or drop it from a tree STAT. This will definitely fix all of these problems that you are having.

  4. Very interesting bug indeed, and definitely something I have managed to stumble into few times, perhaps once a month or so. Though I never figured the cause. Next time, should it happen, I’ll try to investigate, and let you know.

  5. Yes, experienced this one a few days ago, and managed to escape somehow, although I don’t know if I remember all the details precisely.

    In my case the keys got remapped weirdly – most mapped to nothing, but some of them mapped to the wrong ascii characters.

    It seemed to be associated with one app’s session – launching a new session of the app, (navigating directly through the dock) seemed to fix it, but I think I went for a graceful reboot anyway as it was a bit scary to lose so much control.

    I speculated whether it was something to do with num lock at the time, as the numerically labelled alpha keys seemed to be the ones generating output.

    Also I never experienced this particular freakiness before I came to the states, so maybe its a culturally acquired behaviour amongst MIT-connected powerbooks.

    I suggest turning off rendezvous, removing airport cards and blocking up the ethernet port with chewing gum so the little buggers can’t talk to each other.

  6. YES! this has been happening to me every week or two for at least two or three months! The only difference is that Cmd-Tab works as do the function keys and a few others, but the main keys (alphanumerics, arrow keys) work.

    The application I have open do not make a bit of difference. I haven’t tried the force-quit trick, but what does solve the problem is closing all applications (via the mous of course) and logging out/back in. That always solves the problem until it happens a week or two later.


  7. This has been happening to me for a long time on my Powerbook Titanium 15″. I have found somewhat helpful workaround. As you all noted, the keyboard fails to respond after I use Cmd-Tab to switch applications. However, when I use Shift-Cmd-Tab (which is basically just running through the apps in reverse order), then the keyboard becomes usable again.

    So perhaps we all just need to learn to use Shift-Cmd-Tab for app switching.

  8. Hi,

    I’ve had this problem for quite a while, and I’ve been trying to find the magic keystroke that solves the problem. Tonight I think I found it.

    Press Command-Tab and when the switcher is up, press the Escape key. The application switcher should back up one application. Now let go of the Command key. You should have your keyboard back.

    The problem seems to occur when I’m switching applications or rotating through windows and I mash the wrong key. That’s why I spent plenty of quality time hitting keys while the app switcher is visible.

  9. I’ve run into this problem numerous times on OS X 10.4 (Tiger) on a 15″ Powerbook. It is very likely caused by pressing some key combination while using the task switcher.

    Just to add some more information to the mix… When this happens to me, other logged on users are not affected. It is possible to switch from user #1 (who is having the problem) to user #2 (who is not having the problem) and use the keyboard as user #2 but when switching back to user #1 the keyboard is still dysfunctional. User switching is done through the logon screen where the keyboard works (but it doesn’t work directly from user #1’s account since it’s not possible to type the password to switch to user #2’s account). The remedies mentioned seem to work..at least the force-quit one.

    I use COMMAND-TAB and COMMAND-SHIFT-TAB a lot and I also use COMMAND-~ for switching between windows in the same app and I bet it’s some combination of these keys that is causing the problem since I often fat-finger the COMMAND-~.

  10. Same thing here, but all that is disabled is the spacebar. A reboot fixes it.

    Very Strange.

  11. I have the problem on a 12″ powerbook. When it happens I can’t use cntl-delete, cntl-n, cntl-a, etc. However, I can still use cntl-q!
    The difference between me and many users here is that I don’t use cntl-tab to switch between apps.
    Has anyone reported this to Apple?

  12. I get this all the time with a PowerBook G4 and OS X 10.4.2. The only remedy I know other than a reboot is shift-cmd-tab back to the previous app, and then cmd-tab forward again. I sometimes have to go back and forth 2x but never more than that to get my keyboard back.

  13. So, has anyone found a solution to this? I have the same problem on my PowerBook G4 with OS X 10.4.2. I use Command-Tab very often to switch between programs, and the lockup occurs most of time I do it. I just Command-Tab, then Command-Tab again to get back to the original app, and everything works fine, but it sure is a hassle. I have to workaround this issue dozens (and some days, maybe hundreds) of time a day.

  14. Maybe once or twice a day I lose the 9, O (letter), L and . (full stop) and the up and down arrow keys. I’ve rebooted, which occasionally works, but the solution I’ve found most successful is to hold down the fn key (bottom left) and then sweep the keyboard with my hand, trying to catch each key as I make a sweep.

    Not particularly scientific, I grant you, but after trying random permutations of key combinations for 10 minutes the science bit goes out the window…!

    The command + shift + tab and command + tab don’t work for me…

    Any thoughts…?

  15. brand new 12″ PB purchased in late September… I’m having this problem too! Twice in two days, in fact–and never seen it before. This is THE strangest bug I’ve ever seen. Rebooting fixes it, and I’d assume switching users does as well, but it SEEMS to be a hardware problem for some reason regardless. Is there a key command for “keyboard lock”? Maybe we’re hitting it accidentally?

  16. I have had the same problem for several months. The best solution I’ve found is to hit command-tab, and then holding down command and letting go of tab, hit escape. That’s easier than command-shift-tab. It’s shocking that Apple hasn’t fixed this. I had it in 10.3 and now in Tiger. How can we get them moving on it?

  17. I just got it 5 mins ago.
    I used to reboot my powerbook when it happens but know I know that he OSx shortcut keys will work I can try those workarounds. Thanks for the advice.

    Maybe to give you some insight into what is wrong when this happens. The keyboard only listens to two apps at the same time. One of them is OSx and the other is the current app open. Whether it is finder or ITunes. Maybe the frequently mentioned BBedit. When you change apps the keyboard inputs needs to be handled by a different process. Somewhere in that process the handler will get detached from one process and attached to the other. When detached but not attached this problem will occur. Maybe because another event cuts in on interupt level.


  18. Could not figure out why my one year old powerbook g4 has been locking up. I was told I needed a new keyboard…yes, why isn’t Apple addressing this ridiculous problem?? I’m glad I found a website where I could see other people had same problem, as I couldn’t find anything on Apple’s website referring to the problem.

  19. Could not figure out why my one year old powerbook G4 keyboard has been locking up. I was told I needed a new keyboard…yes, why isn’t Apple addressing this ridiculous problem?? I’m glad I found a website where I could see other people had same problem, as I couldn’t find anything on Apple’s website referring to the problem.

  20. Similar [fn] key lock or [numlock] mode lock trouble is seen also in some PowerBook 15″ and 17″ models in Japan.
    One reader suggests pushing [fn] key or pushing [fn]+[numlock] key might solve the problem.

  21. mineis doing everything that everyone elses is doin but one thing ppl didnt mention is, it lets me type my password, also when I try to open mouse and keyboard prefs, it quits. and when I restart, its still doing it. if anyone knows how to fix this, please help

  22. My partner recently let me borrow his 15″ PowerBook G4, mainly because I wanted to test out 10.4. I’m a Windows(by necessity)/Linux guy and a newb with the Mac. What I have found so far is this:
    When Space Bar/Tab/Delete, etc stops functioning a repair permissions also temporarily fixes the problem.
    I use Expose to switch b/t apps and really don’t use the cmd key at all. ( I know I should but I keep thinking it’s a windows key, newb I tell ya. :P)
    The apps I almost always have open have been Firefox, Mail version 2.1, and Finder. If I use safari (2.0.4),mail, and Finder same issue. If I do a search in Spotlight, it starts working again. Weirdest thing I’ve seen I think. I hope someone figures this one out.

  23. I just bought a CoreDuo 2, 15inch MacBook Pro, my ‘fn’ and ‘NumLock’ keys doesn’t work to get to the numbers keypad… instead if I press ‘fn’ and 0 it freeze my keyboard… and I found out that if I pressed ‘fn’ 5 I got it back…

    It’s really annoying, I have reset the keyboard pref, etc… last test was to reboot from the CD and then I could access the keypad from the ‘fn’ key

  24. Hi, my friend told me that Apple already recognized the serious fn key lock problem.
    No solutions for years, sadmac for years.

  25. I have a similar problem on this macbookPro. Apple tab works fine, but the keyboard will lock up on the finder. It will work in all other programs, but not in the finder. Although I have not yet figured out the cause I find that it gets fixed after a forced relaunching of the finder or logging out and logging back in or restarting. I prefer to Force Quit The Finderâ„¢ since it’s the fastest.

  26. I think it is one of the Adobe preferences, specifically something to do with the zoom shortcut.

    This worked for me. Go to the user’s libary/preferences, and drag the *all* the preferences into a spare folder on your desktop. (your preferences folder is now empty).

    Log out, and log back in. Should be fixed. You can then add the preferences that you want back in until the problem pref is found – though I’d rather suggest you simply set new ones.

  27. I have the same problem on the macbook not the mbp. The keyboard doesn’t work on all problems when it happens. Were you able to obtain any help from applecare? replacement or anything?

  28. I am having the same problem on my macbook. The mouse and enter will work, but nothing else (as far as I can tell). But often, if I wait for about a minute it will come back to life. Rebooting works too, but who wants to do that. Often the freeze happens time after time in one session.

  29. Well gang, I hate to be the bearer of bad news, but it appears that this is not an Apple issue or a keyboard issue. I’m currently using a Dual 2.5 GHz PowerPC G5 and have run both Tiger and Leopard systems successfully. After several months of using Leopard, the keys started locking up. I replaced my keyboard, thinking that was the problem. However, the new keyboard was doing the same thing as my old keyboard. So, after talking to our electronics engineer, he indicated that the motherboard has gone bad. Next stop…ebay!


    Great news… it was not the motherboard. I suggest checking your Macintosh System Preference under the System section for UNIVERSAL ACCESS. Click on that, go to KEYBOARD and make sure the “Display pressed keys on screen” is checked. Not sure what keyboard combination started this, but this feature is used for people who can not press more than one key at a time. Oddly, right before I started having problems with the keyboard, I had problems with the computer speaking or beeping at everything the mouse clicked on. This was also fixed under the SEEING and HEARING section. Hope this helps! 🙂


  31. This problem happens to me only when using a cloning function in Adobe Photoshop. Keyboard locks up and I need to reboot. Very frustrating. CS3. Haven’t found a solution after some googling the issue…

  32. I think I fixed it! Mouse Keys in the universal access system prefs has an option to enable mouse keys if option key is pressed 5 times. Using photoshop clone tools requires lots of option key pressing – I unchecked this and it seems to have solved it. Why the OS would have a preference that locks your keyboard if you press option key 5 times is beyond me!

Leave a Reply to Oz Owen Cancel reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s